Windows Service Installation Issues

Issue:

I’ve got the Adeptia suite installed as an administrator and used the option to install the kernel and webrunner as a Windows service, but the services are not installed after completing the installation and reboot. I’m able to start these applications manually and continue with my evaluation but I was curious as to whether this is a limitation of the evaluation or an issue with the installer. I’ve tried uninstalling and re-installing twice following the installation guide so I don’t think it’s a problem with my configuration.

Here's what shown in the Adeptia_SuiteInstallLog.log  (\AdeptiaSuite\AdeptiaSuite-5.3):

Installing Adeptia Suite Kernel as a Windows service...
Ini file decomposed C: \Program Files\AdeptiaSuite\AdeptiaSuite-5.3\AdeptiaServer\ServerKernel\ jsl-Kernel .iniModule name decomposed C: \Program Files\AdeptiaSuite\AdeptiaSuite-5.3\jre\bin\ jsl .exeIni file new C: \Program Files\AdeptiaSuite\AdeptiaSuite-5.3\AdeptiaServer\ServerKernel\ jsl-Kernel .iniIni file path final C:\Program Files\AdeptiaSuite\AdeptiaSuite-5.3\AdeptiaServer\ServerKernel\jsl-Kernel.iniInstalling service with command: C:\Program Files\AdeptiaSuite\AdeptiaSuite-5.3\jre\bin\jsl.exe -ini "C:\Program Files\AdeptiaSuite\AdeptiaSuite-5.3\AdeptiaServer\ServerKernel\jsl-Kernel.ini"CreateService failed - The account name is invalid or does not exist, or the password is invalid for the account name specified. (0x421)Account:

Installing Adeptia Suite WebRunner as a Windows service...
Ini file decomposed C: \Program Files\AdeptiaSuite\AdeptiaSuite-5.3\AdeptiaServer\ServerKernel\ jsl-WebRunner .iniModule name decomposed C: \Program Files\AdeptiaSuite\AdeptiaSuite-5.3\jre\bin\ jsl .exeIni file new C: \Program Files\AdeptiaSuite\AdeptiaSuite-5.3\AdeptiaServer\ServerKernel\ jsl-WebRunner .iniIni file path final C:\Program Files\AdeptiaSuite\AdeptiaSuite-5.3\AdeptiaServer\ServerKernel\jsl-WebRunner.iniInstalling service with command: C:\Program Files\AdeptiaSuite\AdeptiaSuite-5.3\jre\bin\jsl.exe -ini "C:\Program Files\AdeptiaSuite\AdeptiaSuite-5.3\AdeptiaServer\ServerKernel\jsl-WebRunner.ini"CreateService failed - The account name is invalid or does not exist, or the password is invalid for the account name specified. (0x421)Account:

 

Cause:

The error indicates a log in issue with the credentials provided within the installer

 

Solution:

Install the windows services without entering information within the "account" fields

 

 


Have more questions? Submit a request

1 Comments

  • 0
    Avatar
    David Paras

    We decided to use a domain admin to install Adeptia and to run the services as Local System. This will do for now and this is the way to go. The hosting company is now able to run monitoring tools on the Windows Services, they start automatically and are running smooth.

Article is closed for comments.