Issue:
We are unable to access the Log-in page of Adeptia Suite through the Browser. Following errors are thrown inside the kernel logs:
2014-01-20 10:42:40 at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:49', 'com.adeptia.indigo.storage.jdo.JdoEntityManager.retrieve(JdoEntityManager.java:1063)', 'null','null','Error while closing connection[Nested error: org.exolab.castor.jdo.TransactionAbortedException: Nested error: java.sql.SQLException: Io exception: Broken pipe: Io exception: Broken pipe: Nested error: java.sql.SQLException: Io exception: Broken pipe: Io exception: Broken pipe]')
2014-01-20 10:42:40 java.sql.SQLException: OALL8 is in an inconsistent state
2014-01-20 10:42:40 at oracle.jdbc.driver.SQLStateMapping.newSQLException(SQLStateMapping.java:70)
2014-01-20 10:42:40 at oracle.jdbc.driver.DatabaseError.newSQLException(DatabaseError.java:110)
2014-01-20 10:42:40 at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:171)
2014-01-20 10:42:40 at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:227)
Cause:
This issue occurs due to the ojdbc driver for the Oracle Database version : 11.2.0.3 - oracle 11G R2
Solution:
1. Stop Adeptia Services and check that there is no java instance running.
2. Place the attached ojdbc6.jar inside the following folders:
2.1. \AdeptiaServer\ServerKernel\libs.
2.2. \AdeptiaServer\ServerKernel\libs\driver
2.3. \AdeptiaServer\ServerKernel\web\libs
3. Comment and Add the following entry of the ojdbc6.jar located inside the \AdeptiaServer\ServerKernel\etc:
3.1. Comment both the entries of the ojdbc5 jar i.e. #JDBCJAR:OJDBC:ojdbc5.jar
3.2. Below the above entries add the entry of the ojdbc6 jar i.e. JDBCJAR:OJDBC:ojdbc6.jar
4. Restart Adeptia Services.
Comments
0 comments
Article is closed for comments.