Situation:
Every time I try to move activities, after I've done a few of them, Adeptia starts spinning/hanging and then I can't do anything else with it. The first time it happened I restarted my PC and was able to get in again, but right now it's just still spinning and I can't do anything.
I'm also seeing this error in the WebrunnerApplication.log file
ERROR [qtp452256093-1530] storage com.adeptia.indigo.storage.jdo.JdoEntityManager$CustomDatabase.performRetry(JdoEntityManager.java:2857) - ||User||null|||||null|Failed to connect to Backend Database. Performing retries[null]|localhost|
Caused by: org.exolab.castor.jdo.PersistenceException: Nested error: java.sql.SQLException: An attempt by a client to checkout a Connection has timed out.: An attempt by a client to checkout a Connection has timed out.
Cause:
The Adeptia Webrunner is having trouble creating connections to the back-end database
Solution:
Increase the wait time in the system properties.
1) Administer > Setup > Application Settings > Update System Properties
2) Performance Optimization > Webrunner Connection Pool > Webrunner JDO
3) Set abpm.webrunner.jdo.maxWait to 1200000
4) Save the change > Reload Configuration
5) Restart the services
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