Situation:
Our servers where Adeptia Connect/Adeptia Suite is installed don't have Internet Connectivity due to which server is not able to connect the Adeptia license server and gets stuck on the below message for around 10-15 minutes but after the wait Adeptia starts successfully.
Error while checking License status
2020-07-27 12:20:21 java.net.SocketException: Network is unreachable (connect failed): License server cannot be reached
Cause:
This is an environment-specific issue and some customers face this issue when their Linux servers face trouble while generating Random numbers, when the Adeptia tries to generate a random number but JVM is unable to generate the number and gets stuck there for 12-15 minutes.
Solution:
JVM is using file /dev/random by default. If we change it to /dev/urandom for generating random numbers then the issue will be resolved and Adeptia will start in acceptable times within a minute or a two.
Here is a reference URL that helped to resolve this issue:
We need to add Property -Djava.security.egd=f ile:/dev/../dev/urandom in the launcher.properties file present inside for the kernel to resolve this issue. The same property can be also used in Webrunner/AI startup parameters.

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